RADIUS Authentication not working

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
genesys
Posts: 32
Joined: Tue Apr 14, 2020 10:50 pm

RADIUS Authentication not working

Post by genesys » Sun Apr 26, 2020 11:29 pm

I have a Windows Server 2019 with a 2016 AD running.
The server also has the NPS role installed with RADIUS.
The AD contains a User group called "SoftEtherVPNUsers" which contains user John Doe with username john.doe (among others)

I'm trying to setup the SoftEtherVPN such that it will allow all users that are part of this group to connect with VPN.

On the SoftEther VPN server:
-I created the * user and set RADIUS as authentication method.
-I've set the authentication server options to point to the RADIUS server (correct IP) and used the same shared secret as used in the radius client settings configured on the server
On the RADIUS server:
- I configured the SoftEtherServer as valid client, pointing to the SoftEtherServer as valid client using the softEtherServer's IP address as seen from the RADIUs server
- I configured Connection and Network Policies
- I enabled NPS firewall settings
usersettings.png
serversettings.PNG
RadiusClient.PNG
You do not have the required permissions to view the files attached to this post.

genesys
Posts: 32
Joined: Tue Apr 14, 2020 10:50 pm

Re: RADIUS Authentication not working

Post by genesys » Mon Apr 27, 2020 9:38 am

connectionpolicy.png
networkPolicy.png
firewall.PNG
You do not have the required permissions to view the files attached to this post.

xiaowei.zhang
Posts: 3
Joined: Sun Jun 28, 2020 10:28 am

Re: RADIUS Authentication not working

Post by xiaowei.zhang » Sun Jun 28, 2020 11:12 am

@genesys, do you use commercial version of SoftEther? I tried to add user for Radius authentication. unluckily, it tells me that radius and NT domain authentications are only valid for commercial version, rather than my opensource one.

BTW, where to buy commercial version?

Thank you very much.

Post Reply