Unable to connect via mobile 4G router

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Unable to connect via mobile 4G router

Post by Anno » Sun May 12, 2019 5:46 pm

I am not able to connect my softether client to the softether vpn server when I am sitting on a mobile Internet connection.

Does anybody know why?

When I am sitting on a adsl Internet connection anything works perfect.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Sun May 12, 2019 7:19 pm

Isp provider blocks it

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Sun May 12, 2019 8:12 pm

But Softether client use https port 443 which is an open port?

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Mon May 13, 2019 11:17 am

I have the same problem

Different sim/ provider works well

No idea what they block

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Mon May 13, 2019 5:15 pm

Somebody told me it is because that the mobile 4G connection has no public IP address.

Maybe there is some settings in the Softether server or client to avoid this?

Does anybody know?
Last edited by Anno on Tue May 14, 2019 7:13 pm, edited 1 time in total.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Mon May 13, 2019 7:22 pm

Client side does not need poblic ip, only server

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Tue May 14, 2019 4:09 am

But the server side has a public IP address.

But when I am sitting on the client computer and trying to logon to the Softether server and the Internet connection is a mobil 4G connection I can not connect

when I am using a ADSL Internet connection from the same client computer it works.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Tue May 14, 2019 1:48 pm

yes, the same problem

ask your ISP what the f*** they block, it must be the same for me

for me is enough to use sim card from another provider - then it works

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Tue May 14, 2019 4:23 pm

But maybe there a way to avoid it in the Softether Server settings

Does anybody know?

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Tue May 14, 2019 4:52 pm

Do not drink too much......

I spent today more time testing more different SIM cards for internet:

1- Slovak O2 sim - can not work with public IP, but in "normal mode" SE client works perfect
of course can not be used for server

2- Austrian T-mobile - normal mode = nothing works! /not server not client/
public IP mode = both server and client work with it

3- Austrian Yesss - exactly the same as point 2

4- Austrian Drei 3 - in normal mode client works, server of course not
not tested in public IP mode - probably not possible
seems to be as point 1

IS IT CLEAR NOW? F***** ISP PROVIDERS! No magic settings in server

msturm
Posts: 7
Joined: Tue May 14, 2019 5:04 pm

Re: Unable to connect via mobile 4G router

Post by msturm » Tue May 14, 2019 5:13 pm

Hello there,

Let me add some info. I have SAME problem as OP.

I have 4 server set-up. All are the SAME settings, but on different ISPs and locations.

1)Azure WIN server
2)Tmobile ISP WIN server
3)O2 ISP WIN server
4)UPC ISP WIN server

Only LTE routers cannot connect to the server.
They CAN connect to #1 and #2, but they CANNOT connect to #3 and #4.

Mobile hotspot works well on vodafone, tmobile, o2. But those Huaweii Bxxx routers from vodafone not work for all. Only some.

I can connct here, but not there. WHY? same question. No different settings.

Tried things like different ports, ask for blocks by ISP (but some server work, as I said), change router (server-side), change encryption (connection to MTU problems), different authentication.

Even tried set the 4G router to WAN mode (ethernet), then it WORKS. But not on 4G (2 of 4 servers with same setup).


We really need a solution for this :))

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Tue May 14, 2019 7:02 pm

Solution is to use internet

Not to use cripled service based on internet

We should not pay for this!

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Tue May 14, 2019 7:07 pm

Yes, also for me it is hard to understand why the Softether Server denies logon from Softether clients
when the open https protocol 443 is used.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Tue May 14, 2019 7:23 pm

Too many requests on port 443 from client? Do they count them?

Some tools from SE would be welcome to see how far logging in proceeded....

For me it seems the connection is established but immediately drops down


Softether server is not denying logon - the packets from client do not reach server

msturm
Posts: 7
Joined: Tue May 14, 2019 5:04 pm

Re: Unable to connect via mobile 4G router

Post by msturm » Wed May 15, 2019 6:46 am

Well, from same connection, it works towards one SE server, but not to the another one.
Then it should not be provider problem? If it was, it would be problem to all servers (I can test to different SE servers, that's why I don't believe it is by 4G provider)..

I'm not using 443 for it (but I have tried of course).

I can confirm nothing shows up in server logs - the connection does not get there.

It throws error 1, no connection.

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Wed May 15, 2019 8:02 am

But when it works from the same connection to one Softether server but not to another Softether server

What is then the different between the two servers?

msturm
Posts: 7
Joined: Tue May 14, 2019 5:04 pm

Re: Unable to connect via mobile 4G router

Post by msturm » Thu May 16, 2019 12:22 pm

That's the question :) trying to find out, but no luck.

It seems (but it's really only theory), that in some combination it does not work.
The combination means "huawei + vodafone 4G ISP on client side and o2 with huawei "pre-router" on server side" .... when you put out anything from this, it will work:D if you switch isp or device on client, it works. if you connect ethernet wan instead of 4G, it works (same shit router). if you put server behind different connection, it works.

I would need take one server to the location of the other which works to try last option as I have said above :D

I'm desperate, because I would say "it's ISP problem, it just will not work"... But I can see it works somewhere, so there must be a wayyyyyyyyy

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Thu May 16, 2019 12:51 pm

yes, different ISP

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Thu May 16, 2019 4:34 pm

Hope there will be some Softether specialist that can explain what happen, and have a solution.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Thu May 16, 2019 5:47 pm

Anno wrote:
Wed May 15, 2019 8:02 am
But when it works from the same connection to one Softether server but not to another Softether server

What is then the different between the two servers?
you are mixing apples with peaches

Here we try to find out problem from client side - no need port forwarding, it is something else

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Thu May 16, 2019 5:48 pm

Anno wrote:
Thu May 16, 2019 4:34 pm
Hope there will be some Softether specialist that can explain what happen, and have a solution.
If you cut ihternet connectio with axe you will also ask specialist to so;ve it?

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Sun May 19, 2019 11:58 am

I have now tested several SIM 4G Internet connection on my Softether client computer, and all of them it refuse to connect to the Softether server.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Sun May 19, 2019 4:35 pm

Anno wrote:
Sun May 19, 2019 11:58 am
I have now tested several SIM 4G Internet connection on my Softether client computer, and all of them it refuse to connect to the Softether server.
Can you put any of sim cards into public ip regime? For me it then works

I think, as it is phone number based a lot of people have the same ip address

When you go into public regime then you have uniqe ip address alone, even if it is not necessary for client

nour
Posts: 1
Joined: Sun May 19, 2019 5:42 pm

Re: Unable to connect via mobile 4G router

Post by nour » Sun May 19, 2019 5:52 pm

Hi, same problem with connexion via sim card smarthphone.
When using an ethernet (ADSL) it works.

Steal when I use the same Sim card with a Huwei (8 lite) phone, it works !!!!
when i use the same sim card with a xiaomi ( mi max 3) it doesn't ????

The idea is in smartphone something that doesn't support SOFETHER VPN ??


Maybe i should root my smarthphone ??

NB. the phone here is just sharing the internet connexion with a windows PC softether VPN client.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Sun May 19, 2019 7:13 pm

nour wrote:
Sun May 19, 2019 5:52 pm
Hi, same problem with connexion via sim card smarthphone.
When using an ethernet (ADSL) it works.

Steal when I use the same Sim card with a Huwei (8 lite) phone, it works !!!!
when i use the same sim card with a xiaomi ( mi max 3) it doesn't ????

The idea is in smartphone something that doesn't support SOFETHER VPN ??


Maybe i should root my smarthphone ??

NB. the phone here is just sharing the internet connexion with a windows PC softether VPN client.
You described your problem like retarded person, I doubt anybody understands what is your problem...

root phone does not solve anything, just access for you...
What is server wh is client?
You have to describe your hardware

Anno
Posts: 10
Joined: Sun May 12, 2019 5:40 pm

Re: Unable to connect via mobile 4G router

Post by Anno » Sun May 19, 2019 8:12 pm

You don't have to answer anything her if you think I described the problem like retarded person.

People in here try to describe what they discover in the best way.

if you only have negativ commend and you can't say anything good, just leave without comment.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Mon May 20, 2019 7:39 am

Anno wrote:
Sun May 19, 2019 8:12 pm
You don't have to answer anything her if you think I described the problem like retarded person.

People in here try to describe what they discover in the best way.

if you only have negativ commend and you can't say anything good, just leave without comment.
I at least explained about rooting the phone - what was possible to answer.

But I do not see any positive explanation from you on described (for me unsufficiently) problem?

If he needs help he must explain clearly:

- how was server connected to internet
- how was client connected to internet
- where he used SIM cards? server or client?

msturm
Posts: 7
Joined: Tue May 14, 2019 5:04 pm

Re: Unable to connect via mobile 4G router

Post by msturm » Mon May 27, 2019 7:57 am

Still no results - connection to some servers works for me, some not..

I'm not able to spot any difference in settings. Seems like "some specific combination" just will not work.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

VERY LIKELY SOLUTION: Unable to connect via mobile 4G router

Post by sky59 » Tue May 28, 2019 5:45 am

first read this:

https://community.cloudflare.com/t/priv ... work/33461

Can anybody test this:? (I have no possibility at this moment)

Try using not working 4G connection for VPN. But instead of writing server address in text form that has to be resolved by DNS do this:
Using PC try to ping that address, so you get public address in form of 4 numbers already resolved, like this:

ping vpn87482428.softhether.net or whatever server you have

Then write this resolved address in form of number into your cliet setting and try to connect, very likely it might work now.

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

2nd VERY LIKELY SOLUTION: Unable to connect via mobile 4G router

Post by sky59 » Tue May 28, 2019 6:02 am

if your client setting would refuse a pure numbers address like 32.45.11.2 in previous article this is solution:

type into clients setting this address (numbers are from ping)


32.45.11.2.xip.io add just .xip.io


this returns the same IP , some people claim it works ....

for more info visit xip.io

msturm
Posts: 7
Joined: Tue May 14, 2019 5:04 pm

Re: Unable to connect via mobile 4G router

Post by msturm » Tue May 28, 2019 7:58 am

I will test when I get back to that router.

However, it works with softether DDNS to some servers as I have said.
I've already tried our static address of office with that SE server.

WIll let you know about results. But I think I have tested direct address. We will see

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Tue May 28, 2019 10:47 am

msturm wrote:
Tue May 28, 2019 7:58 am
I will test when I get back to that router.

However, it works with softether DDNS to some servers as I have said.
I've already tried our static address of office with that SE server.

WIll let you know about results. But I think I have tested direct address. We will see
yes, exactly! some providers have their own DNS or they block known DNS for VPNs

So for some connection that use normal DNS it can work

msturm
Posts: 7
Joined: Tue May 14, 2019 5:04 pm

Re: Unable to connect via mobile 4G router

Post by msturm » Wed May 29, 2019 6:30 am

Unfortunately, NOPE. DDNS is not the problem (as direct IP entry does not work either).

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Wed May 29, 2019 7:16 am

I also tested it - no chance

I traven today from Austria to Slovakia, I will make more tests - local SIM card also some public WIFIs

I will inform next week

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Mon Jun 03, 2019 1:13 pm

NEWEST TESTS: All tested with Android SE client rooted tablet PMP7170B3GDUO (see neigbouring thread written by me about Android)
all in Slovak Republic, SE server located in Austria

1- home wifi Ovislink --- 3m LAN cable ----- Ovislink ------antena -- 100m air distance --antena--- Ovislink --LAN--NonameRouter ----- Optical internet Orange ===> works without problems

2- 4G internet SWAN usb Dongle with Openwrt router ===> works withou problems

3- wifi in Intercity train Kosice-Bratislava ====> works without problems

4- public wifi in Trencin city ====> works without problems

5- public wifi in Vienna city (back in Austria) =====> DOES NOT WORK

6- 4G A1, yesss operators in Austria =====> DOES NOT WORK

7- 4G Drei operator in Austria =====> works without problems

It seems only 3G 4G mobile internets can have a problem but not all of them
Would be nice if SE staff can give us some glue what operators might be doing, probably such internet is not fully compatible !?

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Thu Jun 06, 2019 1:39 pm

can anybody from SE give us a tip what can be the problem?

internet pages https work, do not they use port 443? no idea what is not supported by some internet connections....

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Mon Jun 10, 2019 7:11 am

Any ideas from se team?

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Thu Jun 13, 2019 8:12 am

thisjun, cedar,

I sent already request to admin, but, can you give me contact please?

I made logs with wireshark for working and not working sim cards...... I need help to understand these logs...

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Mon Jun 17, 2019 12:18 pm

not reacting anyhow leaves me to believe I discovered by mistake a real weakness of SE VPN? so you do not want to make it open as to avoid ISP providers would block it totally very easily?

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Tue Jun 18, 2019 6:52 am

so we will never get any response on this problem?

I hope at least this question you should answer...

you can send me private email on sky59@azet.sk

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Thu Jun 20, 2019 5:14 am

Up

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Sat Jun 29, 2019 6:01 am

It seems from analyzing logs that SE can be blocked easily by not supporting UDP by ISP?

SeanCox
Posts: 1
Joined: Fri Jul 05, 2019 10:52 am

Re: Unable to connect via mobile 4G router

Post by SeanCox » Fri Jul 05, 2019 10:56 am

But when I am sitting on the client computer and trying to logon to the Softether server and the Internet connection is a mobil 4G connection I can not connect

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

Re: Unable to connect via mobile 4G router

Post by sky59 » Fri Jul 05, 2019 6:54 pm

Some 4g work.

I found that not working sim when switched to dynamic ip works.

I have logs for this from wireshark.

But softether team have absolutely no interest! !

sky59
Posts: 206
Joined: Tue Sep 11, 2018 5:58 pm

PROBABLY PROBLEM DISCOVERED

Post by sky59 » Thu Jul 11, 2019 11:53 am

I made a lot of tests and found out following:

If I use for server internet connection coming from router with port forwarding, then client can connect to it if it has public IP address, it can not connect if client is on ISP mobile provider local network

If I use for server directly genuine internet connection using USB dongle with publoc IP SIM card, then client can connect with whatever connection, public, local....

So it seems our routers are not correctly forwarding messages on port 443 to SE server, in reality, no message comes to server at all
Or firewall is set up in a funny way that does not forward anything if not coming from public IP?

Those that have similar problem, can you try to use direct internet connection for server or use OpenWrt router with enabled everything everywhere?

Post Reply